Time format in Epic Epoch and Network Mapping

CorText Manager Q&A forumCategory: Time processingTime format in Epic Epoch and Network Mapping
Hannah asked 7 months ago

Hello !
I’m working on an Europresse corpus. It seems that the time format is the right one (year-month-day). However, when I try to use Epic Epoch (after conducting a term extraction), the bump graph only gives me “abstract” time data (“80”, “100”, “120”… instead of year for example). I don’t understand what I’m missing in the parameters of Term Extraction or Epic Epoch, or if I’m supposed to reformat time data beforehand.
I have the same issue with dynamic network mapping.
Thank you !
Hannah

1 Answers
Géraldine Enderli Staff answered 6 months ago

Dear Hannah,
The issue you’re raising is likely due to the fact that when you drop data from Europresse into CorText Manager, the “Data Parsing” script will process the temporal data present in the data file by transforming them into a certain number of years, months, weeks or days since January the 1st of any “Starting year” you define. This information will be recorded in the “ISIpubdate” field of the sqlite database in your dashboard project (e.g. if you have a date “2023-01-01” in your raw data and define a “Time granularity” as “year” with a “Starting year” at “2000”, the “ISIpubdate” field in the sqlite database will contain the information “23”; see Data Parsing documentation).
It is then this “ISIpubdate” field (and not the “Date” field, which is the “raw” information from your html file extracted from Europresse) which is automatically taken as time parameter in the various CorText Manager scripts (such as Epic Epoch, Network mapping…).
So, if you want to display the year in Cortext Manager scripts’ outputs/graphics, you’ll need to correct the “ISIpubdate” field in your sql database. For that:

  • Do a “matching” file in LibreOffice (the values you call “abstract” time data (=present in the “ISIpudate” field after the parsing) in the first column and the “correct” corresponding year you want in the second column). (see List indexer documentation)
  • Upload your matching file in your project
  • Run the “Corpus List Indexer” script with the following parameters : « Time Steps » for “Field”; « No » for “Define a custom list of entities”, “Yes” for “Add a dictionary of equivalent strings” then enter the matching file ; « Yes » for « List indexation advanced settings” and enter “ISIpubdate” for « New indexation name (optional)”.

If this doesn’t solve the problem, you’ll have to invite us in your project, so that we can investigate further.
Also note that when you open scripts’ outputs/graphs in CorText Manager, you have an “Edit labels” option which allows you to make manual corrections/modifications to the “labels” of your graphs (see Label editor documentation).
Best.

Hannah replied 6 months ago

That is very clear, thank you so much !